Opened 10 years ago

Closed 10 years ago

#10231 closed defect (fixed)

Grid: Screen reader does not speak column header info when shift-tab from data cell

Reported by: Becky Gibson Owned by: Becky Gibson
Priority: high Milestone: 1.4
Component: DojoX Grid Version: 1.4.0b
Keywords: a11y Cc:
Blocked By: Blocking:

Description

This is a consequence of fixing #9756 that I thought was related to the browser. It is not a browser issue.

To reproduce tab into a grid. Focus will go to a column header and JAWS 11 will speak the contents of the column header. Tab again to put focus into a data cell. JAWS 11 will speak the contents of the data cell. Shift-tab back to the column header - JAWS does NOT speak the column header contents.

Since focus is not longer directly set on column header cells (see #9756), I need to set focus back to the grid domNode so that the browser will pick up the use of aria-activedescendant to indicate the active column header cell.

Change History (1)

comment:1 Changed 10 years ago by Becky Gibson

Resolution: fixed
Status: newclosed

(In [20692]) fixes #10231. Need to set focus onto the grid domNode so the browser can pick up the use of aria-activedescendant to identify the current column header.

Note: See TracTickets for help on using tickets.