Opened 10 years ago

Closed 10 years ago

#10224 closed defect (invalid)

Data Presentation - Charting is not working when Deciamal Sepataror is no DOT (.)

Reported by: Roberto Mosqueda Owned by: Eugene Lazutkin
Priority: high Milestone: tbd
Component: Charting Version: 1.4.0b
Keywords: Data Presentation - G11Y Cc: drschwar@…, tmayeur@…, dave.clark@…, deanw@…, Adam Peller
Blocked By: Blocking:

Description

Testing Type: Globalization

Browsers Affected: IE 6,7 and 8, Firefox 3.0 and 3.5.

Problem Description: When using comma as Decimal Separator, the data from the chart Series is truncating. It is supposed that when the Locale machine is changed, e.g. France, the chart should take comma as decimal separator defined in the JSON files.

Steps to Reproduce:

1.- Set a JSON with values using comma as decimal separator. e.g. 12,56 2.- Open the browser 3.- Open http://dleadt.torolab.ibm.com/dl/charts/testd.html. Be sure you are using the JSON file above.

Actual Result : The values are truncating and comma is not taken as part of the value.

Expected Result: The comma should be taken as part of the value when the LOCALE machines is set with a language that used comma as decimal separator.

Change History (2)

comment:1 Changed 10 years ago by Adam Peller

JSON must use "." as a decimal separator. Data should not be localized, only the presentation

comment:2 Changed 10 years ago by Adam Peller

Resolution: invalid
Status: newclosed

Please do try using values with decimals and enough digits to require comma separators, perhaps even percentages if that's used in charting, and make sure that's properly represented in the UI. Some locales even have different representations for "%" I think. The raw data simply must use Javascript notation for numbers, which is what JSON follows. It's also best practice to have raw data that is locale neutral, especially since there is no way to indicate the locale of the data (which would not necessarily be the same locale used to present to the user)

Note: See TracTickets for help on using tickets.