Opened 10 years ago

Closed 5 years ago

#10220 closed enhancement (patchwelcome)

'create link' removes markup

Reported by: rsccag Owned by: Jared Jurkiewicz
Priority: low Milestone: future
Component: Editor Version: 1.3.2
Keywords: link markup editor Cc:
Blocked By: Blocking:

Description

Creating a link with the 'create link' dialog(plugin) removes all existing markup when applied to a text. Afterwards markup can be applied to the link again with other dialogs.

Attachments (2)

dojobug1.jpg (20.0 KB) - added by rsccag 10 years ago.
create link on text with markup
dojobug2.jpg (12.6 KB) - added by rsccag 10 years ago.
markup is removed

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by rsccag

Attachment: dojobug1.jpg added

create link on text with markup

Changed 10 years ago by rsccag

Attachment: dojobug2.jpg added

markup is removed

comment:1 Changed 10 years ago by bill

Owner: set to jared

comment:2 Changed 10 years ago by bill

Owner: changed from jared to Jared Jurkiewicz

comment:3 Changed 10 years ago by bill

Milestone: tbd1.5

Since this isn't a regression bumping to 1.5. (I just tried it in 1.3 and it's a problem there too.)

I can see the reason for wanting this, although not sure how to solve it as having a "description" field in the tooltip dialog implies plain text.

comment:4 Changed 10 years ago by Jared Jurkiewicz

Type: defectenhancement

This is not a bug, it's deisgned to work that way currently. This is a feature request. Marking as such.

comment:5 Changed 9 years ago by Jared Jurkiewicz

Milestone: 1.5future

comment:6 Changed 6 years ago by bill

Priority: highlow

comment:7 Changed 5 years ago by bill

Resolution: patchwelcome
Status: newclosed

Unlikely this will be fixed unless someone wants to supply a patch (including a test case).

Note: See TracTickets for help on using tickets.