Opened 10 years ago

Closed 8 years ago

#10202 closed defect (worksforme)

Enhanced Grid Accessibility - Scrolling on firefox is not working properly

Reported by: Roberto Mosqueda Owned by: evan
Priority: high Milestone: 1.6
Component: DojoX Grid Version: 1.4.0b
Keywords: EnhancedGrid a11y Cc: David Schwartz, tmayeur@…, Nathan Toone, hwcdl@…, Becky Gibson
Blocked By: Blocking:

Description

Testing Type: Accessibility

Browsers Affected: FF 3.0 and 3.5

Problem Description: Scrolling on firefox is not working properly when using key tab to navigate keyboard focus.

Steps to Reproduce:

1.- Open the browser
2.- Go to /test_enhanced_grid.html
3.- Enlarge page text using ctrl + '+'
4.- Use the tab key to move focus to the data grid table.

Actual Result : Once the keyboard focus is on the table (columns, rows or cells) you can´t see it, because the page is not scrolled on an automatic way.

Expected Result: It should work as other browser because on other browsers the page is scrolled automatically when the table gets the keyboard focus.

Change History (7)

comment:1 Changed 10 years ago by Nathan Toone

Owner: changed from Nathan Toone to Evan

comment:2 Changed 10 years ago by Nathan Toone

Keywords: EnhancedGrid added; Datagrid removed

comment:3 Changed 10 years ago by David Schwartz

Let's defer to 1.5

comment:4 Changed 10 years ago by Adam Peller

Milestone: tbd1.5

comment:5 Changed 9 years ago by Adam Peller

Milestone: 1.51.6

comment:6 Changed 8 years ago by bill

Owner: changed from Evan to evan

comment:7 Changed 8 years ago by evan

Resolution: worksforme
Status: newclosed

Closing, not reproduced with 1.6b1

Note: See TracTickets for help on using tickets.