Opened 10 years ago

Closed 10 years ago

#10198 closed defect (fixed)

doh.robot not typing SHIFT + *_ARROW

Reported by: Enrique Rafael Muñoz Flores Owned by: haysmark
Priority: high Milestone: 1.4
Component: TestFramework Version: 1.3.2
Keywords: doh robot arrow shift Cc:
Blocked By: Blocking:

Description

Appearently the doh.robot is not working out the combination *_ARROW + SHIFT, I tried *_ARROW + CTRL and it worked, also TAB + SHIFT works ok, so it looks like its that certain key combination which is not working.

Checked out the DOHRobot.java, and its console, but everything was fine. Although for some reason they did not include the log("Releasing key"); for, ctrl, alt and altgraph, on DOHRobot.java Lines 1036-1047.

OS: Windows XP Lang/region: Spanish(Mexico), Mexico Keyboard: Latin America, United States (International).

Attachments (5)

doh.robot-test.html (2.5 KB) - added by Enrique Rafael Muñoz Flores 10 years ago.
Here is a simple example, the text should be selected or deselected when you SHIFT+RIGHT/LEFT_ARROW.
doh.robot-test.2.html (2.5 KB) - added by haysmark 10 years ago.
Test case as intended.
10198.patch (6.6 KB) - added by haysmark 10 years ago.
Fixes #10198. Fixed the FocusManager? test failure on Windows machines by automatically disabling numlock in the robot code before pressing SHIFT+arrow keys.
10198.2.patch (598 bytes) - added by haysmark 10 years ago.
Fixes #10198. Reorder if statement to only check numlock on Windows.
DOHRobot.jar (42.3 KB) - added by haysmark 10 years ago.
Robot jar with code to work with non-Windows systems.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 years ago by bill

Owner: changed from alex to haysmark

Please attach a test case using the attach file button.

Changed 10 years ago by Enrique Rafael Muñoz Flores

Attachment: doh.robot-test.html added

Here is a simple example, the text should be selected or deselected when you SHIFT+RIGHT/LEFT_ARROW.

Changed 10 years ago by haysmark

Attachment: doh.robot-test.2.html added

Test case as intended.

comment:2 Changed 10 years ago by haysmark

I reproduced this issue. I was able to make it work by pressing numlock on my keyboard to disable numlock.

comment:3 Changed 10 years ago by haysmark

This is a known issue in Sun's JRE:

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4838497

It is a 6 year old ticket so don't count on it getting fixed. The solution may be to code the applet to turn off numlock at the start of each test via the Java AWT Toolkit API already embedded in the applet.

comment:4 Changed 10 years ago by Douglas Hays

Milestone: tbd1.4

This problem is causing [dijit/tests/_base/robot/FocusManager.html] to fail.

Changed 10 years ago by haysmark

Attachment: 10198.patch added

Fixes #10198. Fixed the FocusManager? test failure on Windows machines by automatically disabling numlock in the robot code before pressing SHIFT+arrow keys.

comment:5 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [20705]) Fixes #10198. Fixed the FocusManager?? test failure on Windows machines by automatically disabling numlock in the robot code before pressing SHIFT+arrow keys.

Changed 10 years ago by haysmark

Attachment: 10198.2.patch added

Fixes #10198. Reorder if statement to only check numlock on Windows.

Changed 10 years ago by haysmark

Attachment: DOHRobot.jar added

Robot jar with code to work with non-Windows systems.

comment:6 Changed 10 years ago by haysmark

Resolution: fixed
Status: closedreopened

[20705] regresses robot testing on Linux. I've attached the fix, which is to check that the OS is windows before invoking getLockingKeyState.

comment:7 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: reopenedclosed

(In [20715]) Fixes #10198. Proxy commit for haysmark. Reorder if statement to only check numlock on Windows.

Note: See TracTickets for help on using tickets.