Opened 10 years ago

Closed 9 years ago

#10183 closed defect (worksforme)

Enhanced grid Accessibility - Tab key order is lost

Reported by: Roberto Mosqueda Owned by: evan
Priority: high Milestone: 1.6
Component: DojoX Grid Version: 1.4.0b
Keywords: EnhancedGrid a11y Cc: David Schwartz, tmayeur@…, Nathan Toone, hwcdl@…, Becky Gibson
Blocked By: Blocking:

Description

To Reproduce:
1.- Open a valid browse
2.- Go to /test_enhanced_grid.html
3.- Move focus to the rows selection column (see image1.gif)
4.- Click ctrl+tab to go to another window opened on the browser(see image2.gif)
5.- Click ctrl+tab to back to the Enhanced data grid page, as you can see on image3.gif the keyboard focus is moved to the next focusable element, and it should remain on the same element.
Browsers affected: Firefox 3, 3.5 and Safari 4

Attachments (3)

image1.gif (28.1 KB) - added by Roberto Mosqueda 10 years ago.
image2.gif (24.3 KB) - added by Roberto Mosqueda 10 years ago.
image3.gif (26.1 KB) - added by Roberto Mosqueda 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by Roberto Mosqueda

Attachment: image1.gif added

Changed 10 years ago by Roberto Mosqueda

Attachment: image2.gif added

Changed 10 years ago by Roberto Mosqueda

Attachment: image3.gif added

comment:1 Changed 10 years ago by Nathan Toone

Owner: changed from Nathan Toone to Evan

comment:2 Changed 10 years ago by Nathan Toone

Keywords: EnhancedGrid added; Datagrid removed

comment:3 Changed 10 years ago by David Schwartz

Please move to 1.5

comment:4 Changed 10 years ago by Nathan Toone

Milestone: tbd1.5

comment:5 Changed 10 years ago by Adam Peller

Milestone: 1.51.6

comment:6 Changed 9 years ago by bill

Owner: changed from Evan to evan

comment:7 Changed 9 years ago by evan

Resolution: worksforme
Status: newclosed

Not able to reproduce this issue in trunk anymore, by using e.g. selector test case

Note: See TracTickets for help on using tickets.