Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#10169 closed defect (fixed)

ComboButton: disabled doesn't look disabled (regression)

Reported by: bill Owned by: Eugene Lazutkin
Priority: high Milestone: 1.4
Component: Dijit - Form Version: 1.4.0b
Keywords: Cc:
Blocked By: Blocking:

Description

Noticed in test_Button.html (on safari) that pressing the "disable all" button doesn't make the ComboButton look disabled; it doesn't change at all. Used to work in 1.3.

Change History (5)

comment:1 Changed 10 years ago by Douglas Hays

Owner: set to Eugene Lazutkin
Priority: normalhigh

seems to be caused by [20284] dojo/_base/declare.js

comment:2 Changed 10 years ago by Douglas Hays

severity: normalmajor

[20284] is also causing readOnly TextBox? widgets in WebKit? to have invisible text. References #10170.

comment:3 Changed 10 years ago by bill

This problem is because dijit.byId("comboCreate") instanceof dijit.form.Button is returning false now, rather than true. (comboCreate is a ComboButton.) The inheritance chain is pretty simple:

dojo.declare("dijit.form.ComboButton", dijit.form.DropDownButton, { ...

...

dojo.declare("dijit.form.DropDownButton", [dijit.form.Button, dijit._Container, dijit._HasDropDown], { ...

comment:4 Changed 10 years ago by Eugene Lazutkin

Resolution: fixed
Status: newclosed

Fixed in [20665].

comment:5 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.