Opened 10 years ago

Closed 8 years ago

#10160 closed defect (worksforme)

Enhanced grid Accessibility - Check boxes not selected when using ctrl+click and high contrast

Reported by: Roberto Mosqueda Owned by: evan
Priority: high Milestone: 1.6
Component: DojoX Data Version: 1.4.0b
Keywords: EnhancedGrid a11y Cc: David Schwartz, tmayeur@…, Nathan Toone, hwcdl@…, Becky Gibson
Blocked By: Blocking:

Description


To Reproduce:

1.- Open a valid browser
2.- Go to /test_enhanced_grid.html
3.- Start JAWS
4.- Go to Control Panel - Accessibility Options. On the Display tab, check the option to "Use High Contrast". Select the "Settings" button and select a high contrast scheme such as "White or Black". Select the OK button and then the Apply button.
5.- Switch focus back to the browser.
6.- Move the keyboard focus to one check box and click on ctrl+space, as you can see (image2.gif) the check box is selected.
7.- Move the keyboard focus to one check box and click on ctrl+click, as you can see (image3.gif) the check box is not marked as selected.

Attachments (2)

image2.gif (20.0 KB) - added by Roberto Mosqueda 10 years ago.
image3.gif (49.0 KB) - added by Roberto Mosqueda 10 years ago.

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by Roberto Mosqueda

Attachment: image2.gif added

Changed 10 years ago by Roberto Mosqueda

Attachment: image3.gif added

comment:1 Changed 10 years ago by Roberto Mosqueda

Browsers affected: IE7. IE6, IE8, Firefox 3 and Firefox 3.5

comment:2 Changed 10 years ago by Nathan Toone

Owner: changed from anonymous to Evan

comment:3 Changed 10 years ago by Roberto Mosqueda

Please ignore instruction 3, we are not using Jaws for this test

comment:4 Changed 10 years ago by Adam Peller

Component: GeneralDojoX Data
Keywords: a11y added

comment:5 Changed 10 years ago by Nathan Toone

Keywords: EnhancedGrid added; Datagrid removed

comment:6 Changed 10 years ago by David Schwartz

Let's defer to 1.5

comment:7 Changed 10 years ago by Adam Peller

Milestone: tbd1.5

comment:8 Changed 9 years ago by Adam Peller

Milestone: 1.51.6

comment:9 Changed 8 years ago by bill

Owner: changed from Evan to evan

comment:10 Changed 8 years ago by evan

Resolution: worksforme
Status: newclosed

Not able to reproduce anymore in trunk by using e.g indirect selection test case

Note: See TracTickets for help on using tickets.