Opened 10 years ago

Closed 10 years ago

#10147 closed defect (fixed)

IE: html_rtl.html is failing

Reported by: Douglas Hays Owned by: Douglas Hays
Priority: high Milestone: 1.4
Component: Core Version: 1.4.0b
Keywords: Cc: bill, James Burke
Blocked By: Blocking:

Description

bill noticed that when you run dojo/tests/runTests.html in IE6 or 7 that html_rtl.html fails, although it seems to work when the test html file is run standalone. The problem is that is unhides DIV elements and then checks for the position without waiting for the elements to render. The timing problem has been there a while but has been made worse since dojo.position is a lot faster than dojo.coords.

Change History (2)

comment:1 Changed 10 years ago by Douglas Hays

Status: newassigned
Summary: IE: html_rtl.html is fialingIE: html_rtl.html is failing

comment:2 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

(In [20614]) Fixes #10147. Add Deferred processing to html_rtl.html to give the browser time to render.

Note: See TracTickets for help on using tickets.