Opened 10 years ago

Closed 8 years ago

#10117 closed defect (duplicate)

moveable nodes can be moved out of viewport

Reported by: Thomas Pfeiffer Owned by: Eugene Lazutkin
Priority: high Milestone: future
Component: DnD Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

Currently, dialogs can be dragged out of the viewport and then can neither be moved back anymore nor closed. When it is moved out of the viewport completely, even esc does not work anymore and for some reason F5 doesn't reload the page anymore. Only clicking the reload button works. So the user is almost completely trapped with an unusable page. This happens in Firefox 3 and Chrome. It does not happen in IE6 (haven't tested any other browsers yet).

Change History (7)

comment:1 Changed 10 years ago by bill

Component: GeneralDijit
Owner: anonymous deleted
Summary: Dialog can be moved out of viewportDialog: can be moved out of viewport

I don't understand, isn't at least the part that you grabbed to drag it still in the viewport?

comment:2 Changed 10 years ago by Douglas Hays

Run dijit/tests/test_Dialog.html using Firefox 3/Windows.
Click "Show Dialog".
Click the title of the dialog and drag it to the top of the physical screen (past the browser client top).
Release the mouse button and now you can't see the dialog title bar any more.
IE dragging stops at the top of the browser client area but FF3 keeps going.

comment:3 Changed 10 years ago by bill

Component: DijitDnD
Owner: set to Eugene Lazutkin
Summary: Dialog: can be moved out of viewportmoveable nodes can be moved out of viewport

Oh I see... OK, this is a problem with the DnD code, same thing happens in dojo/tests/dnd/test_moveable.html on the table with the handle (happens on both FF and safari BTW).

comment:4 Changed 10 years ago by Eugene Lazutkin

Milestone: tbd1.4.1
Status: newassigned

comment:5 Changed 10 years ago by Eugene Lazutkin

Milestone: 1.4.1future

Need to find a good way to lock a dragged item inside a viewport.

comment:6 Changed 8 years ago by PEM

I believe this bug is a dupe and fixed : http://bugs.dojotoolkit.org/ticket/12238

comment:7 Changed 8 years ago by Karl Tiedt

Resolution: duplicate
Status: assignedclosed

Definitely appears to be a dupe of #12238 Closing as such based on testing test_Dialog.html in nightly

Note: See TracTickets for help on using tickets.