Opened 10 years ago

Closed 10 years ago

#10115 closed defect (invalid)

problem while moving data between two DataGrids in DOJO 1.4 beta

Reported by: vishwajeet Owned by: Nathan Toone
Priority: high Milestone: tbd
Component: DojoX Grid Version: 1.4.0b
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

I have been using DOJO 1.3.2 for last few days in one of my application. In the course of development I have used lot of features from this version of DOJO e.g. dijit.Tree, DataGrid?, Containers and so on. I have just started migrating whatever development I have done so far to recently released DOJO 1.4 beta version after Nick suggested me to do so. While testing on beta version I think I am facing some problems while moving data between two DataGrids?.

I am attaching one HTML and one JS file here. You need to rename expandNode.txt to expandNode.js as my Thunderbird doesn't permit attachments with *.js extension.

To reproduce the same problem I am facing with 1.4b you have to just access the HTML page and then click on the "Add Item to the Selected Carton" tab on the right side. Now hit the "Search" button inside the container and here you will see two grids empty one at the top and grid with few data rows at the bottom. You may have to scroll down a bit to see the bottom DataGrid? as I haven't been able to figure out how to set their sizes correctly. There is one button labeled "Remove Selected Items" at the bottom of upper grid while another one labeled "Add Selected Items" located below the bottom grid. Idea is to move data items between these two grids by using these two buttons. If you select few of the rows in the bottom grid and then click on "Add Selected Items" button it should move these selected items to the upper empty grid. Again, if you select few of the just currently moved rows in the upper grid and click on "Remove Selected Items" button these selected items should be moved back to the bottom grid. Everything is just working fine in 1.3.2 but I am observing some strange behaviour with 1.4b. If you don't see any obvious problems then,

  • Click on "Add Sub-Carton to the Selected Carton" tab,
  • Click on the "Add Carton" button in the opened tab (it should add a tree node to the tree located at the left side of page).
  • Click on the newly added tree node
  • Now again click on "Add Item to the Selected Carton" tab and follow the same procedure with respect to moving rows between two grids.

I will be really glad if someone can try running attached code with 1.4b and verify if there are indeed some problems with DataGrid?.

Vishwajeet

Attachments (3)

chlndtl.html (10.4 KB) - added by vishwajeet 10 years ago.
expandNode.2.js (9.2 KB) - added by vishwajeet 10 years ago.
expandNode.js (9.2 KB) - added by vishwajeet 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by vishwajeet

Attachment: chlndtl.html added

Changed 10 years ago by vishwajeet

Attachment: expandNode.2.js added

Changed 10 years ago by vishwajeet

Attachment: expandNode.js added

comment:1 Changed 10 years ago by Nathan Toone

Resolution: invalid
Status: newclosed

This is not a bug. You should not be calling targetGrid.update, srcGrid.update, targetGrid.resize, or srcGrid.resize in your moveSelectedItems function. All you need to do is add the item (or remove it) from the store.

Note: See TracTickets for help on using tickets.