Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#10111 closed defect (fixed)

Flashing when clicking menus / dialogs (FF/linux)

Reported by: Pete Smith Owned by: bill
Priority: high Milestone: 1.4
Component: Dijit Version: 1.4.0b
Keywords: menu dialogs Cc:
Blocked By: Blocking:

Description

This is reproducible in FF 3.5.3 ( I am on Fedora 11 - 64 bit)

http://download.dojotoolkit.org/release-1.4.0b1/dojo-release-1.4.0b1/dijit/tests/test_Menu.html

1.) Load page. 2.) Click File.

You will see a white flash, just for a fraction of a second, which will cover the word "random text" in the upper left. Although this doesn't look that bad on this page, on my site , with a standard graphic in the upper left, you can see the graphic flash in the menu or dialog for a second. It looks pretty nasty. I have zero problems on 1.3.2.

For another example, see:

http://download.dojotoolkit.org/release-1.4.0b1/dojo-release-1.4.0b1/dijit/tests/test_Dialog.html

When clicking show dialog, you will get a flash of white before it shows.

Attachments (1)

test_Menu.html (21.3 KB) - added by Pete Smith 10 years ago.
All I did was put a logo in the upper left.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 10 years ago by bill

Milestone: tbd1.4
Owner: set to bill
Status: newassigned

Yes, this is from #10041 although perhaps technically you could call it a different bug (or a different manifestation) since you are talking about Menus not Dialogs. But anyway it's the BackgroundIframe thing.

comment:2 Changed 10 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [20577]) Workaround flashing problem on FF3.5 when dialog/menu/etc. is first shown. Thanks Sam. Fixes #10041, #10111 !strict.

comment:3 Changed 10 years ago by Pete Smith

Resolution: fixed
Status: closedreopened

I still see this on my system with dojo 1.4b2. When I click a menu, I see my logo image (in upper left) flash in the menu.

Changed 10 years ago by Pete Smith

Attachment: test_Menu.html added

All I did was put a logo in the upper left.

comment:4 Changed 10 years ago by Pete Smith

I attached a test case. When you click a menu,you can see the GenomeQuest? logo flash really fast inside the menu.

comment:5 Changed 10 years ago by bill

Which browser and OS flashes? Does it reproduce on FF3.5/win?

comment:6 Changed 10 years ago by Pete Smith

Firefox 3.5 Fedora 11 64 Bit, I see it. I don't see it on FF3.5 / Win Xp. Darn. It is quite apparent though in Linux. The more I assume these are the same the more differences I find.

comment:7 Changed 10 years ago by Pete Smith

I thought possibly it was Firebug installed, but I tried and I don't see it in Windows. There is a sort of "pulse" that happens when a menu is shown, I even see some activity in the low right bar of Firefox (like a page is loading)...

comment:8 Changed 10 years ago by bill

Yeah, that's the <iframe> behind the menu, loading it's URL (even though it's not a real URL).

In [20635] there was one line removed about setting the iframe opacity, before the

node.appendChild(iframe);

you could try putting that back in to see if it makes a difference.

comment:9 Changed 10 years ago by Pete Smith

I put that line back in - no difference. I guess it is because FF linux is so fast, it tries to load the non real url. Any other ideas?

comment:10 Changed 10 years ago by bill

Summary: Flashing when clicking menus / dialogsFlashing when clicking menus / dialogs (FF/linux)

No, but I'm curious if it's happening every time or just the first time? Cougar put in caching so the <iframe> (in theory) is only getting created once and thus there should only be one load of the URL, no matter how many times you show the Menu/Dialog?.

comment:11 Changed 10 years ago by Pete Smith

Absolutely every time I click a menu, I see my logo flash in the menu for a split second. No matter how many times.

comment:12 Changed 10 years ago by bill

Resolution: fixed
Status: reopenedclosed

(In [20766]) prevent initial menu flash (first time menu is shown) on mac and linux, refs #5776, fixes #10111, !strict.

comment:13 Changed 10 years ago by Pete Smith

I can confirm, after adding top: "-9999px" to line 148, its fantastic. Thanks bill.

Note: See TracTickets for help on using tickets.