Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#10110 closed defect (fixed)

Enhanced grid - There are two focus indicators at the same time

Reported by: Roberto Mosqueda Owned by: evan
Priority: high Milestone: 1.4
Component: DojoX Grid Version: 1.4.0b
Keywords: EnhancedGrid Cc: David Schwartz, tmayeur@…, Nathan Toone, hwcdl@…
Blocked By: Blocking:

Description


When you are using the keyboard focus indicator and you move the mouse to another location, other focus indicator for the mouse is displayed instead of only move the one already displayed

Instructions to reproduce the problem:

1.- Open a valid browser
2.- Go to /test_enhanced_grid.html
3.- Set the keyboard focus indicator over one of the cells
4.- As you can see on image1.gif, two focus indicators are displayed, one for the keyboard focus and another one for the mouse focus.
Note: the problem is occurring on all supported browsers:
IE6, IE7, IE8 Firefox 3.0.14 & 3.5.3 Chrome 3.0.195.25 Safari 4.0.3
But it is visually more highlighted on IE6

Attachments (1)

image1.gif (43.6 KB) - added by Roberto Mosqueda 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by Roberto Mosqueda

Attachment: image1.gif added

comment:1 Changed 10 years ago by Nathan Toone

Owner: changed from Nathan Toone to Evan

comment:2 Changed 10 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [20661]) Patch from Evan. Fix the checkbox painting issue and cell over indicator in IE6. Fixes #10110, #10112 !strict

comment:3 Changed 10 years ago by Adam Peller

Milestone: tbd1.4

comment:4 Changed 10 years ago by Nathan Toone

Keywords: EnhancedGrid added; Datagrid removed

comment:5 Changed 9 years ago by bill

Owner: changed from Evan to evan
Note: See TracTickets for help on using tickets.