Opened 10 years ago

Closed 9 years ago

#10109 closed defect (duplicate)

Enhanced grid - Diferences between using ctrl+space and ctrl+click when working with columns

Reported by: Roberto Mosqueda Owned by: evan
Priority: high Milestone: 1.6
Component: DojoX Grid Version: 1.4.0b
Keywords: EnhancedGrid Cc: David Schwartz, tmayeur@…, Nathan Toone, hwcdl@…
Blocked By: Blocking:

Description


There are differences when you use ctrl+click and ctrl+space on the colums.

Instructions to reproduce the problem:
1.- Open a valid browser
2.- Go to /test_enhanced_grid.html
3.- Move the keyboard focus indicator to the first column and use ctrl+space to select it(see image1.gif)
4.- Move the keyboard focus indicator to the third column and click shift+space, as you can see (image2.gif) columns 1, 2 and 3 are selected, this is the expected behavior.
5.- Move the mouse pointer to the first column and use ctrl+click to select it(see image3.gif)
6.- Move the keyboard focus indicator to the third column and click shift+space, as you can see (image4.gif) only the third column is selected.

Problem: it supposes that using ctrl+space and ctrl+click should have the same behavior and it works on rows but the behavior is different on columns as you can see.

Browsers affected: IE6, IE7, IE8 Firefox 3.0.14 & 3.5.3 Chrome 3.0.195.25 Safari 4.0.3

Attachments (4)

image1.gif (40.0 KB) - added by Roberto Mosqueda 10 years ago.
image2.gif (42.2 KB) - added by Roberto Mosqueda 10 years ago.
image3.gif (40.0 KB) - added by Roberto Mosqueda 10 years ago.
image4.gif (41.3 KB) - added by Roberto Mosqueda 10 years ago.

Download all attachments as: .zip

Change History (13)

Changed 10 years ago by Roberto Mosqueda

Attachment: image1.gif added

Changed 10 years ago by Roberto Mosqueda

Attachment: image2.gif added

Changed 10 years ago by Roberto Mosqueda

Attachment: image3.gif added

Changed 10 years ago by Roberto Mosqueda

Attachment: image4.gif added

comment:1 Changed 10 years ago by Adam Peller

Owner: changed from Nathan Toone to Evan

comment:2 Changed 10 years ago by David Schwartz

It's not clear what behavior you're expecting; can you describe? FYI, SPACE alone will select a single column.

Entering CTRL+SPACE or clicking CTRL+click on a selected column should de-select it without affecting the other columns.

comment:3 in reply to:  2 Changed 10 years ago by Roberto Mosqueda

Replying to drschwartz:

It's not clear what behavior you're expecting; can you describe? FYI, SPACE alone will select a single column.

Entering CTRL+SPACE or clicking CTRL+click on a selected column should de-select it without affecting the other columns.

RE: I would expect that when I use ctrl+space or ctrl+click, the application should work in the same way, but it doesn´t happen with the scenario described above, the application has two different behaviours when using one of both options, maybe you could clarify which of them is the correct behaviour, anyway the defect is because when you use ctrl+space or ctrl+click and after that you use shift + space shouldn't have a difference on the actions but now there is a difference

comment:4 Changed 10 years ago by Roberto Mosqueda

This ticket is related with problem reported on ticket:http://bugs.dojotoolkit.org/ticket/10099

Evan comment: FF and Webkit always deem CTRL+SPACE as CTRL, and SHIFT+SPACE as SHIFT, so we couldn't capture the exact CTRL+SPACE or SHIFT+SPACE events.

Please defer this defect to version 1.5, by David's recomendation.

comment:5 Changed 10 years ago by Adam Peller

Milestone: tbd1.5

comment:6 Changed 10 years ago by Nathan Toone

Keywords: EnhancedGrid added; Datagrid removed

comment:7 Changed 10 years ago by Adam Peller

Milestone: 1.51.6

comment:8 Changed 9 years ago by bill

Owner: changed from Evan to evan

comment:9 Changed 9 years ago by evan

Resolution: duplicate
Status: newclosed

Same cause and duplicate with #10098, ctrl + space event is not natively supported by browser

Note: See TracTickets for help on using tickets.