Opened 10 years ago

Closed 10 years ago

#10105 closed defect (fixed)

Portlet cannot be placed in a specific column of the GridContainer

Reported by: Shane O'Sullivan Owned by: bill
Priority: high Milestone: 1.4
Component: DojoX Widgets Version: 1.4.0b
Keywords: Cc:
Blocked By: Blocking:

Description

Setting the "column" attribute on a dojox.widget.Portlet to specify the column it should be placed in a GridContainer? does not work.

The "column" attribute added by GridContainer? to the dijit._Widget class is not added to the Portlet for some reason.

Change History (4)

comment:1 Changed 10 years ago by Shane O'Sullivan

Status: newassigned

comment:2 Changed 10 years ago by Shane O'Sullivan

(In [20602]) Refs #10105 Adding a test case for this issue

comment:3 Changed 10 years ago by Shane O'Sullivan

Owner: changed from Shane O'Sullivan to bill
Status: assignednew

Reassigning to Bill, as I think he worked on the dojo.extend and dojo.declare functionality last. This issue is caused by the "column" attribute not being inherited from dijit._Widget by dojox.widget.Portlet

comment:4 Changed 10 years ago by Shane O'Sullivan

Resolution: fixed
Status: newclosed

Fixed in [20610]

Note: See TracTickets for help on using tickets.