Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#10104 closed defect (fixed)

[patch][cla]IE8 fileuploader bug

Reported by: himius Owned by: Mike Wilcox
Priority: high Milestone: 1.4.1
Component: DojoX Form Version: 1.4.0b
Keywords: fileuploader, flash Cc: Tom Trenka
Blocked By: Blocking:

Description

Hi there,

I have a problem with dojox uploader in IE8 browser.

Message: Building SWF failed. Line: 352 Symbol: 8Code: 0 URI-code: http://cs2.him.dev.techs.int/js/lib/dojox/embed/Flash.js

Look at attachment of this bug.

Thanks in advance, Him.

Attachments (3)

bug_263.jpg (99.5 KB) - added by himius 10 years ago.
IE8 file uploader bug
patch_Flash.txt (987 bytes) - added by jfcunat 9 years ago.
cney_FileUploader.html (9.7 KB) - added by CnEY 9 years ago.
Test for long URL to swf

Download all attachments as: .zip

Change History (18)

Changed 10 years ago by himius

Attachment: bug_263.jpg added

IE8 file uploader bug

comment:1 Changed 10 years ago by dante

Owner: changed from dante to Mike Wilcox

comment:2 Changed 10 years ago by Mike Wilcox

Milestone: tbdfuture

This isn't enough information. Are you trying to include the SWF in a form? Or a hidden div? I'm not sure what the picture is telling me. Please attach a simple test case that reproduces the error.

comment:3 Changed 9 years ago by Mike Wilcox

(In [20641]) Refs #10104, #9996, #9793, Fixes #10196 - fixed style regressions. Also added some groundwork for making FileUploader? work in Dialog and TabContainer? (the ability to be initially hidden... tricky task)

comment:4 Changed 9 years ago by Mike Wilcox

Resolution: wontfix
Status: newclosed

Not enough information. Closing.

comment:5 Changed 9 years ago by jfcunat

Resolution: wontfix
Status: closedreopened

I have the same problem depending on the length of the path where dojo is located.

Length of the path used in Flash.js can be too long leading to problem in SWF creation on IE. Using FlashVars? parameters with <param name="FlashVars?" instead of parameters in the path url solves the problem.

Changed 9 years ago by jfcunat

Attachment: patch_Flash.txt added

comment:6 Changed 9 years ago by jfcunat

Could this patch be included in a 1.4.1 release ?

comment:7 Changed 9 years ago by Mike Wilcox

Milestone: future1.4
Version: 1.3.21.4.0b

comment:8 Changed 9 years ago by Adam Peller

Cc: Tom Trenka added

comment:9 Changed 9 years ago by Adam Peller

Summary: IE8 fileuploader bug[patch][cla]IE8 fileuploader bug

comment:10 Changed 9 years ago by Adam Peller

Milestone: 1.41.4.1

comment:11 Changed 9 years ago by Mike Wilcox

Resolution: fixed
Status: reopenedclosed

(In [21029]) Fixes #10104 - Moved FlashVars? from a query on the movie path to the FlashVars? param. This prevents errors in IE when the URl gets too long.

comment:12 Changed 9 years ago by Adam Peller

Resolution: fixed
Status: closedreopened

needs to be applied to 1.4.1, if this works out.

comment:13 Changed 9 years ago by Mike Wilcox

Resolution: fixed
Status: reopenedclosed

(In [21030]) Fixes #10104 - FlashVars? fix, committed to the 1.4 branch.

comment:14 Changed 9 years ago by CnEY

Maybe it's just me, but this doesn't seem to fix the issue in IE6 for some reason, or at least not in the case in which it's happening to me. Anyone else notice this?

Changed 9 years ago by CnEY

Attachment: cney_FileUploader.html added

Test for long URL to swf

comment:15 Changed 9 years ago by CnEY

Actually, I may have figured out that cached SWF objects in my IE6 was at fault - I reinstalled Flash and it seems to be working now. Sorry for the false alarm, this bug looks like it can stay closed. :)

I did attach a test (based off test_FileUploader.html, runs in the same directory) that should be able to reproduce the issue on dojo 1.3.2, for anyone interested.

Note: See TracTickets for help on using tickets.