Opened 10 years ago

Closed 8 years ago

#10098 closed defect (wontfix)

Enhanced grid - CRTL + Space didn't work

Reported by: pilar Owned by: evan
Priority: high Milestone: 1.6
Component: DojoX Grid Version: 1.4.0b
Keywords: EnhancedGrid Cc: drschwar@…, tmayeur@…, hwcdl@…, toonetown@…
Blocked By: Blocking:

Description

CRTL + Space should do the same as CTRL + click, but when you use the CTRL + Space on columns didn't work, works like the page down bottom.

To Reproduce:

1.- Open a valid browse
2.- Go to /test_enhanced_grid.html
3.- Select 1 column using CTRL + click
4.- Now try to select the next column using CTRL + Space.



Browsers affected :

  • IE6, IE7, IE8
  • Firefox 3.0.14 & 3.5.3
  • Chrome 3.0.195.25
  • Safari 3.2.3 & 4.0.3

Change History (8)

comment:1 Changed 10 years ago by Nathan Toone

Owner: changed from Nathan Toone to Evan

comment:2 Changed 10 years ago by David Schwartz

Please defer to 1.5

comment:3 Changed 10 years ago by Nathan Toone

Milestone: tbd1.5

comment:4 Changed 10 years ago by Nathan Toone

Keywords: EnhancedGrid added; Datagrid removed

comment:5 Changed 10 years ago by David Schwartz

Browsers seem unable to create the proper events for ctrl+space. Please move to 1.5.

comment:6 Changed 9 years ago by Adam Peller

Milestone: 1.51.6

comment:7 Changed 8 years ago by bill

Owner: changed from Evan to evan

comment:8 Changed 8 years ago by evan

Resolution: wontfix
Status: newclosed

ctrl+space are not supported by browsers(both onkeydown and onkeypress), so closing this due to browser limitation

Note: See TracTickets for help on using tickets.