Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#10089 closed defect (fixed)

Enhanced grid - Nested & Unary Sort section get shorter

Reported by: pilar Owned by: evan
Priority: high Milestone: 1.4
Component: DojoX Grid Version: 1.3.2
Keywords: EnhancedGrid Cc: David Schwartz, tmayeur@…, Nathan Toone
Blocked By: Blocking:

Description

Using Safari Ver. 3.2.2 as browser and the Zoom option, the Nested & Unary sections are every time shorter, even you lose of sight the elements (numbers , remove, ascending or descending sort)

To reproduce:

1.- Open a Safari 3.2.3 browser
2.- Go to /test_enhanced_grid.html
3.- Use Ctrl ++ for Zoom the page

Attachments (4)

Image 2.JPG (83.3 KB) - added by pilar 10 years ago.
Image 3.JPG (78.9 KB) - added by pilar 10 years ago.
EnhancedGrid_Safari4.jpg (65.3 KB) - added by Evan 10 years ago.
10089.patch (2.8 KB) - added by Adam Peller 10 years ago.
posting patch for Evan: fix the column header select region hovering width in Safari4 and Chrome4

Download all attachments as: .zip

Change History (13)

Changed 10 years ago by pilar

Attachment: Image 2.JPG added

Changed 10 years ago by pilar

Attachment: Image 3.JPG added

comment:1 Changed 10 years ago by Adam Peller

Cc: David Schwartz Nathan Toone added; drschwar@… hwcdl@… toonetown@… removed
Component: GeneralDojoX Grid
Owner: changed from anonymous to Evan

comment:2 Changed 10 years ago by bill

We aren't supporting Safari3 anymore but does this happen on Safari4?

comment:3 Changed 10 years ago by Evan

Looks good in Safari4 as "EnhancedGrid_Safari4.jpg" shows.

Changed 10 years ago by Evan

Attachment: EnhancedGrid_Safari4.jpg added

comment:4 Changed 10 years ago by pilar

The problem was only with Safari 3 using the zoom.

But Safari 3 is not longer supported. Please close this defect. Thanks

comment:5 Changed 10 years ago by Nathan Toone

Resolution: wontfix
Status: newclosed

Don't support safari 3

Changed 10 years ago by Adam Peller

Attachment: 10089.patch added

posting patch for Evan: fix the column header select region hovering width in Safari4 and Chrome4

comment:6 Changed 10 years ago by Nathan Toone

Keywords: EnhancedGrid added

comment:7 Changed 10 years ago by Adam Peller

Resolution: wontfixfixed

(In [20696]) Patch from Evan fixes #10089 - the column header select region hovering width in Safari4 & Chrome4 fixes #10108 - Bottom keyboard focus indicator getting clipped on the sort choices !strict

comment:8 Changed 10 years ago by bill

Milestone: tbd1.4

comment:9 Changed 9 years ago by bill

Owner: changed from Evan to evan
Note: See TracTickets for help on using tickets.