Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#10082 closed defect (fixed)

NumberTextBox over Link problem in IE8

Reported by: PhilippC Owned by:
Priority: high Milestone: 1.4
Component: Dijit - Form Version: 1.3.2
Keywords: NumberTextBox, Dialog, IE8, Link Cc:
Blocked By: Blocking:

Description

I noticed that in IE8 the NumberTextBox? does not work properly when placed in a Dialog and when the Dialog is moved so that the NumberTextBox? is over a link (<a href="...">...</a>). If the user clicks in the NumberTextBox?, the NTB does not get the focus but instead the link is clicked. I attached a modified test_Dialog.html (from dijit/tests/) to demonstrate this.

Attachments (1)

test_Dialog.html (2.2 KB) - added by PhilippC 10 years ago.
modified test_Dialog.html from dijit/tests to demonstrate the problem.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by PhilippC

Attachment: test_Dialog.html added

modified test_Dialog.html from dijit/tests to demonstrate the problem.

comment:1 Changed 10 years ago by bill

Milestone: 1.3.31.4
Resolution: fixed
Status: newclosed

Fixed in [20473], presumably this is the same problem as #10041.

comment:2 in reply to:  1 Changed 10 years ago by PhilippC

Replying to bill:

Fixed in [20473], presumably this is the same problem as #10041.

Yes, the problem is gone in the nightly build (10/11/2009), however, simply taking the fix of [20473] into 1.3.2. does not fix it there. Is there a simple way to do this (as I need to release this week)?

comment:3 Changed 10 years ago by bill

Hmm, that's strange, I thought just that change would work. You could try getting [20187] too, to use the onresize() event instead of CSS expressions. (Could also use IE8's developer page to check if the iframe is there and has the right size.)

comment:4 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.