Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#10073 closed defect (fixed)

TreeGrid: double-click on expando causes error

Reported by: Nathan Toone Owned by: Karl Tiedt
Priority: high Milestone: 1.6.2
Component: DojoX Grid Version: 1.6.1
Keywords: Cc: Evan
Blocked By: Blocking:

Description

Run any treegrid test and double-click on an expando to get the error this._click[0] is undefined.

Change History (12)

comment:1 Changed 10 years ago by Nathan Toone

Resolution: fixed
Status: newclosed

(In [20516]) Fixes #10073 - prevent crash when double-clicking on expando !strict

comment:2 Changed 9 years ago by Karl Tiedt

I am still seeing this bug in 1.6, where this._click[0] ends up being null or undefined so trying to access .rowIndex throws an error

Would you object to making the onCellClick (where this propagates from) read like this

	onCellClick: function(e){
		// summary:
		//		Event fired when a cell is clicked.
		// e: Event
		//		Decorated event object which contains reference to grid, cell, and rowIndex
		this._click[0] = this._click[1];
		this._click[1] = e;
		if(!this.edit.isEditCell(e.rowIndex, e.cellIndex)){
			this.focus.setFocusCell(e.cell, e.rowIndex);
		}
		// prevent null events from propagating as double clicks
		if(this._click[0] == null) { this._click.shift(); }
		this.onRowClick(e);
	},

comment:3 Changed 9 years ago by Karl Tiedt

Milestone: 1.4
Resolution: fixed
Status: closedreopened
Version: 1.3.21.6.1

Going to reopen this to apply more definitive patch since this bug is still reproducible in 1.6

comment:4 Changed 9 years ago by Karl Tiedt

Owner: changed from Nathan Toone to Karl Tiedt
Status: reopenednew

comment:5 Changed 9 years ago by Karl Tiedt

Resolution: fixed
Status: newclosed

(In [25141]) fixes #10073 - click[0] was sometimes hitting nulls which caused this error to still come up

comment:6 Changed 9 years ago by Karl Tiedt

Milestone: tbd

comment:7 Changed 9 years ago by Adam Peller

Cc: evan added
Milestone: tbd1.7

patch is in the pipeline for 1.7. Did you want this to be considered for backporting?

comment:8 in reply to:  7 Changed 9 years ago by Karl Tiedt

Replying to peller:

patch is in the pipeline for 1.7. Did you want this to be considered for backporting?

Yes please, as well as #11188 if you can Evan

comment:9 Changed 9 years ago by Adam Peller

[25140] was ktiedt's checkin to fix this bug

comment:10 Changed 9 years ago by evan

Backported to 1.6 branch with [25157]

comment:11 Changed 9 years ago by Adam Peller

Milestone: 1.71.6.2

comment:12 Changed 8 years ago by Evan

Cc: Evan added; evan removed
Note: See TracTickets for help on using tickets.