Opened 10 years ago

Closed 10 years ago

#10072 closed defect (fixed)

Regression: Editor returns escaped HTML instead of text in IE8

Reported by: haysmark Owned by: Nathan Toone
Priority: high Milestone: 1.4
Component: DojoX Grid Version: 1.3.1
Keywords: Cc:
Blocked By: Blocking:

Description

http://archive.dojotoolkit.org/nightly/checkout/dojox/grid/tests/test_edit_dijit.html

In IE8, open an Editor cell and close it. The text is now surrounded by escaped paragraph tags where there were none before. Grid's Editor handler just passes through the value to and from Editor, so this is more likely a regression in Editor.

You see it first emerge going from 1.3 to 1.3.1:

http://download.dojotoolkit.org/release-1.3.0/dojo-release-1.3.0/dojox/grid/tests/test_edit_dijit.html

http://download.dojotoolkit.org/release-1.3.1/dojo-release-1.3.1/dojox/grid/tests/test_edit_dijit.html

Attachments (1)

fix.patch (641 bytes) - added by Jared Jurkiewicz 10 years ago.
Patch that turns off HTML escaping so that the output of RTE displays correctly.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by Jared Jurkiewicz

This isn't editor. This is the escapeHTMLInData crap of grid.

comment:2 Changed 10 years ago by Jared Jurkiewicz

Component: EditorDojoX Grid

Since grid-auto-escapes the HTML, this, of course, means Rich Text (HTML markup), isn't handled as HTML markup when viewed in grid by default.

The 'fix' for this is to disable the HTML escaping, of course. The grid folks may want to consider allowing HTML on a cell by cell basis, instead of a flat on or off for everything. Cell-by-cell makes sense esp when dealing with using Editor in the grid.

Attached is a patch that fixes the testcase by simply turning off HTML escaping. The grid folks may want to consider the alternate of allowing per-cell escaping as a better solution than this (which is why I didn't check it in).

Changed 10 years ago by Jared Jurkiewicz

Attachment: fix.patch added

Patch that turns off HTML escaping so that the output of RTE displays correctly.

comment:3 Changed 10 years ago by Jared Jurkiewicz

Owner: changed from Jared Jurkiewicz to Nathan Toone

comment:4 Changed 10 years ago by Nathan Toone

Jared -

Feel free to check in this fix to the test case (I do not currently have my machine available, and cannot check in.) I will create a new bug with the enhancement request to support turning off html escaping per-cell.

Thanks.

comment:5 Changed 10 years ago by Adam Peller

see #10086

comment:6 Changed 10 years ago by Adam Peller

Priority: normalhigh

comment:7 Changed 10 years ago by Nathan Toone

Resolution: fixed
Status: newclosed

(In [20557]) Fixes #10072 - prevent escaping of HTML

Note: See TracTickets for help on using tickets.