Opened 13 years ago

Closed 13 years ago

#1004 closed defect (wontfix)

Tree creation error in 0.3.1

Reported by: guest Owned by: ilia
Priority: high Milestone: 0.9
Component: Widgets Version: 0.3
Keywords: Tree Cc:
Blocked By: Blocking:

Description

Tree widget creation with the following call failed: dojo.widget.createWidget("Tree", {widgetId:"adminTree"});

The following error message shown: dojo.widget.Parse: error: [TypeError: node.markSelected is not a function, file: https://localhost:8443/ep5cm/template-resources/js/dojo/dojo.js, line: 260]

Debugged into it and noticed that it is caused by the "dojo.lang.isUndefined(this.eventNames[name])" in function initiliaze. It falsely returns false and "this.eventNames" is not intialized properly.

Fixed it by replacing "dojo.lang.isUndefined(this.eventNames[name])" by "typeof this.eventNames[name] =="undefined" ".

Change History (3)

comment:1 Changed 13 years ago by dylan

Milestone: 0.5

comment:2 Changed 13 years ago by dylan

Owner: changed from anonymous to ilia

comment:3 Changed 13 years ago by ilia

Resolution: wontfix
Status: newclosed

See TreeV3, report if issue open for it

Note: See TracTickets for help on using tickets.