Custom Query (18300 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (7 - 9 of 18300)

1 2 3 4 5 6 7 8 9 10 11 12 13
Ticket Resolution Summary Owner Reporter
#3088 IE 7.0 displays ActiveX permission block when XslTransform is used Tom Trenka guest
Description

When running in IE 7.0, if the dojo.xml.XslTransform? is used, a security warning is given (yellow bar across the top of the page) that IE wants to run MSXML 5.0.

Apparently, Microsoft is supposed to be shipping MSXML 6.0 together with IE7 and they have marked MSXML 5.0 as "insecure" (still works fine in IE6).

http://blogs.msdn.com/xmlteam/archive/2006/10/23/using-the-right-version-of-msxml-in-internet-explorer.aspx

I am using dojo 0.4.3 and I have fixed the problem by changing the file XslTransform?.js to rearrange the order in which the versions are checked:

========

var IS_IE = dojo.render.html.ie;

var ACTIVEX_DOMS = [

"Msxml2.DOMDocument.6.0", "Msxml2.DOMDocument.3.0", "Msxml2.DOMDocument.5.0", "Msxml2.DOMDocument.4.0", "MSXML2.DOMDocument", "MSXML.DOMDocument", "Microsoft.XMLDOM"

]; var ACTIVEX_FT_DOMS = [

"Msxml2.FreeThreadedDOMDocument.6.0", "MSXML2.FreeThreadedDOMDocument.3.0", "Msxml2.FreeThreadedDOMDocument.5.0", "MSXML2.FreeThreadedDOMDocument.4.0"

]; var ACTIVEX_TEMPLATES = [

"Msxml2.XSLTemplate.6.0", "MSXML2.XSLTemplate.3.0", "Msxml2.XSLTemplate.5.0", "Msxml2.XSLTemplate.4.0"

];

=====

This seems to fix the problem for me.

#5748 DomParser: see what it would take to implement a version of dojo.query on the result. Tom Trenka Tom Trenka
Description

See what it will take to implement a version of dojo.query on a document produced by this.

#5760 DomParser: mutations patch Tom Trenka liucougar
1 2 3 4 5 6 7 8 9 10 11 12 13
Note: See TracQuery for help on using queries.